myoverlay/app-admin/ansible/ansible-10.2.0.ebuild
László Valkó 7b5bdcb5a1 Added app-admin/ansible-10.2.0.
Added app-admin/ansible-core-2.17.2.
2025-03-29 06:22:00 +01:00

30 lines
688 B
Bash

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{11..13} )
inherit distutils-r1 pypi
DESCRIPTION="Model-driven deployment, config management, and command execution framework"
HOMEPAGE="https://www.ansible.com/"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
RESTRICT="test"
RDEPEND=">=app-admin/ansible-core-2.17.0
<app-admin/ansible-core-2.18"
python_compile() {
local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
distutils-r1_python_compile
}
python_install() {
local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
distutils-r1_python_install
}