Added xen 4.9.1 patch.

This commit is contained in:
László Valkó 2018-07-12 05:14:18 +02:00
parent d5cea1f50f
commit b2d26d9fd1

View file

@ -0,0 +1,31 @@
diff --git a/xen/arch/x86/Makefile b/xen/arch/x86/Makefile
index b5cb5e3..812667c 100644
Gentoo patch for a Xen build failure with the following error:
efi/buildid.o: file not recognized: File format is ambiguous
efi/buildid.o: matching formats: coff-x86-64 pe-x86-64
Tested with
app-emulation/xen-4.9.1-r1 USE=efi
binutils: x86_64-pc-linux-gnu-2.28.1
profile: default/linux/amd64/17.0/hardened
Write this patch to
/etc/portage/patches/app-emulation/xen-4.9.1-r1/000-binutils-file-format.patch
and emerge xen.
SEE ALSO
https://forums.gentoo.org/viewtopic-t-1072366.html
https://lists.xenproject.org/archives/html/xen-devel/2016-12/msg00799.html
https://gist.github.com/daemon32/4632925cca4eb53ead231fe373b6a53d
--- a/xen/arch/x86/Makefile
+++ b/xen/arch/x86/Makefile
@@ -156,6 +156,7 @@ EFI_LDFLAGS += --major-image-version=$(XEN_VERSION)
EFI_LDFLAGS += --minor-image-version=$(XEN_SUBVERSION)
EFI_LDFLAGS += --major-os-version=2 --minor-os-version=0
EFI_LDFLAGS += --major-subsystem-version=2 --minor-subsystem-version=0
+EFI_LDFLAGS += -b coff-x86-64
$(TARGET).efi: VIRT_BASE = 0x$(shell $(NM) efi/relocs-dummy.o | sed -n 's, A VIRT_START$$,,p')
$(TARGET).efi: ALT_BASE = 0x$(shell $(NM) efi/relocs-dummy.o | sed -n 's, A ALT_START$$,,p')